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This document and its parts can be copied or provided to a third party only with the express permission of PSI. 

The contents of this manual have been verified to correspond to the specifications of the device. However, deviations cannot 

be ruled out. Therefore, a complete correspondence between the manual and the real device cannot be guaranteed. The 

information in this manual is regularly checked, and corrections may be made in subsequent versions.  

The visualizations shown in this manual are only illustrative. 

This manual is an integral part of the purchase and delivery of equipment and its accessories and both Parties must abide 

by it. 
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1 INFORMATION BEFORE USING SPECTRAPEN DEVICE 

Please read this manual carefully before operating the device. If not sure about anything in this manual, please contact the 

manufacturer for clarification. 

 

By accepting the device, the customer agrees to follow the instructions in this guide. 

Always follow instructions in this manual while working with the SpectraPen device or doing the maintenance. 

It is forbidden to interfere with the hardware or software of the SpectraPen device in any way without previous agreement 

with the manufacturer. 

 

The following table explains basic highlight symbols used in this manual. 

Symbol Description 

 

Important information, read carefully. 

 

Additional information. 

Tab. 1 Used symbols. 
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2 TECHNICAL SPECIFICATION 

Spectrum measurement 

Spectral range 
380 nm - 790 nm (LM 510 UVIS) 
640 nm - 1050 nm (LM 510 NIR) 

Spectral response half width 9 nm 

FWHM bandwidth 7 nm 

Wavelength reproducibility +/- 0.5 nm 

Spectral Straylight -30 dB 

Integration time 
Set automatically 
From 5 ms to 10 s 

Number of pixel 256 

Dimension of pixel 0.5 x 15.8 mm 

Data storage and transfer 

Internal memory capacity Up to 16 Mbit 

Internal data logging Up to 4,000 measurements  

Data transfer USB cable 

PC software SpectraPen 1.1 (Windows 7 and higher) 

Battery 

Type Li-Ion rechargeable battery 

Capacity 2600 mAh 

Max. charging current 0.5 A 

Charging Via USB port - PC, power bank, USB charger, etc. 

Battery life 
48 hours typical with full operation  
Low battery indicator 

Other 

Optical entrance Cosine corrector 

Display Touchscreen 240 x 320 pixel; 65535 colors 

Built in GPS module 
Ultra-high sensitivity down to -165dBm 
High accuracy of <1.5 m in 50% of trials 

Size 180 x 75 x 40 mm 

Weight 300 g 

Operating conditions 
Temperature: 0 to +55 °C 
Relative humidity: 0 to 95 % (non-condensing) 

Storage conditions 
Temperature: -10 to +60 °C 
Relative humidity: 0 to 95 % (non-condensing) 

Warranty 1 year parts and labor 
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3 GENERAL INFORMATION 

SpectraPen LM 510 is a handheld portable spectroradiometer that is ideal as a general-purpose instrument for research 

and for agricultural applications. SpectraPen LM 510 measures in radiometric or photometric units the intensity of the light 

irradiance and is calibrated for visible light in the range of 380 – 780 nm for UVIS version and 640 – 1,050 nm for NIR 

version. SpectraPen is used for irradiance measurements, illuminance measurements and CIELAB chromaticity diagram 

measurements. SpectraPen is especially useful for rapid measurements of spectral light quality, for monitoring of artificial 

lighting and for quantification of light radiation.  

The SpectraPen is powered by a built-in, rechargeable Li-Ion battery and does not require a PC or any other bulky accessory 

for operation. The SpectraPen touch screen displays continuously the wavelength and intensity readings and their spectral 

traces including correlated color temperature index. All recorded data are automatically stored in the internal memory of 

the device. The SpectraPen includes a comprehensive software package (for a PC) comprising full system control, data 

acquisition and data processing. 

The built-in GPS module and splash-proof case are ideal for field use of the SpectraPen and make this device well suited 

for wide scope of environmental, agricultural and ecological applications such as monitoring of artificial lighting used in 

horticulture industry or light source testing. 

Parameters measured by the SpectraPen: 

Scope - quantitative light intensity at different wavelengths 

• Irradiance spectrum [µW.cm-2.nm-1] 

• Photon flux density spectrum [µmol.m-2.s-1.nm-1] 

Light Meter - absolute light intensity at defined range of wavelengths of the electromagnetic spectrum  

• Irradiance [W.m-2] in user defined range of the electromagnetic spectrum 

• Photon flux density [µmol.m-2.s-1] in user defined range of the electromagnetic spectrum 

• Illuminance [Lux] - total luminous flux incident on a surface, per unit area 

• PAR [µmol.m-2.s-1]* 

Chromaticity Diagram CIE1931 - quality of color space and color temperature of the light source  

• CIE color coordinates* 

• Correlated color temperature – for LED * 

• Color rendering index 

Users defined formulas in SpectraPen software 

* Valid only for LM 510-UVIS version of SpectraPen LM 510 

 

SpectraPen versions: 

 

LM 510-H/UVIS (Fig. 1a) 
Cosine corrector facing up (horizontal position); limited space measurement; wavelength range 340 – 780 nm 
 
LM 510-H/NIR (Fig. 1a) 
Cosine corrector facing up (horizontal position); limited space measurement; wavelength range 640 – 1,050 nm 
 
LM 510-V/UVIS (Fig. 1b) 
Cosine corrector facing front (vertical position); field measurement; tripod mount; wavelength range 340 – 780 nm 
 
LM 510-V/NIR (Fig. 1b) 
Cosine corrector facing front (vertical position); field measurement; tripod mount; wavelength range 640 – 1,050 nm 
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Fig. 1a) SpectraPen LM 510-H. b) SpectraPen LM 510-V. 

 

3.1  DEVICE  DE SCRIPTION  

Cosine corrector 

The optical sensor of the SpectraPen and the cosine corrector, is placed inside of the black box positioned on the front 

panel which protects the optics from dirt or moisture. The sensor is covered with a teflon ring placed either on top 

(horizontal position) or in front (vertical position) of the optical head depending on the device version. 

Integration time of the detector is set automatically according to the ambient light intensity up to a maximum integration 

time of ten seconds. 

Each SpectraPen device is calibrated with the certified light source AvaLight - DH-BAL-CAL. Calibration certificate is 

provided by the manufacturer for each device.  

 

The sensor should be always dust and dirt free and protected when not in use, as any scratches on 

the surface might interfere with measurements and results  

Color touch screen display 

The SpectraPen is operated via touch screen by using provided stylus. Instructions on how to operate the unit are provided 

on page 16. 

 

No sharp objects should be used when operating the SpectraPen via touch screen. It is 

recommended to use provided stylus when making selections on the touch screen. 
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Connector for USB cable 

USB connector on the device together with the USB cable provided, is used for re-charging the device battery and for 

operation of the SpectraPen directly from a PC via the SpectraPen software (downloaded to PC). 

Power button 

Power button is the main Switch ON/OFF button.  

 

  

 

Fig. 2 SpectraPen LM 510-H. 
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4 LIST OF COMPONENTS 

Carefully unpack the carton. You should have received the following items: 

• SpectraPen 

• Carrying Case 

• Textile Strap for Comfortable Wearing 

• SpectraPen Operating Manual (on a USB flash disc) 

• SpectraPen software and driver (on a USB flash disc) 

• USB cable 

• Stylus 

Other Accessories or Optional Features (according to your specific order) 

 

 

 

For USB connection you need to have the USB driver installed on the PC. The driver can be found on 

the installation disk (USB driver folder).  

If any item is missing, please, contact PSI. Also check the carton for any visible external damage. If 

you find any damage, notify the carrier and PSI immediately. The carton and all packing materials 

should be retained for inspection by the carrier or insurer. 

For customer support, please write to: support@psi.cz 
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5 CARE AND MAINTENANCE 

SpectraPen 

• Never submerge the device in water!  

• The device should not come in contact with any organic solvents, strong acids or bases.  

• Keep the optical sensor cover clean and dry. If cleaning is needed, use soft, non-abrasive tissue.  

• Do not use sharp objects for touch screen operation. 

 

 

It is recommended to re-calibrate the device by the manufacturer every 2 years. 

 

Li-ion battery 

• Battery power lasts approximately 48 hours when the SpectraPen is operated continuously. 

• Avoid fully discharging of the battery. 

• Do not keep the battery at full charge for long periods of time. Allow for it to discharge. 

• High temperatures shortens battery life. 

• If the battery can no longer be charged, please contact PSI for replacement battery and installation 

instructions. 
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6 GETTING STARTED 

Switch on the device by pressing the Power button and follow next steps to perform the measurements. In case the device 
battery is not charged connect the SpectraPen to the PC or to USB adaptor (not included) via the USB cable and charge the 
battery. 

Before any parameters are measured with SpectraPen device dark spectrum scan must be performed. Dark spectrum scan 
must be performed everytime the device is switched on or periodically during prolong operation period of the device. A 
dark spectrum scan is the equivalent of zeroing the instrument and the user should perform a dark scan each time changes 
are made in the Setup menu  

 

 

The measurements with the SpectraPen cannot be made until the dark spectrum calibration is 

performed. 

 

6.1  DARK SPE CTRUM CALIBRATION  

Dark spectrum calibration is an essential step for zeroing of the device before live spectrum is obtained.  

• On the opening screen of the device select Get Dark Spectrum >press OK (Fig. 3) 

• Cover the cosine corrector head (optical sensor) completely with a dark cloth  to ensure that it is in total darkness 

during the calibration step. It is important that no outside light reaches the detector and interferes with the 

measurement. 

 
Fig. 3 Dark spectrum calibration – part 1. 

• Press OK and wait until the Dark spectrum calibration step is completed (Fig. 4). Please note that the sensor head must 

be covered throughout the entire process of calibration. 

• Dark spectrum is automatically stored into the device memory and used for background subtraction. Dark spectrum 

calibration scan is normalised to the surrounding temperature and is relative to the detector integration time.  

 

In case surrounding temperature is rapidly changed during the calibration step or during the 

measurement, the SpectraPen will automatically ask for new dark spectrum calibration. 
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Fig. 4 Dark spectrum calibration – part 2. 

 

6.2  MEASUREMENT  

SpectraPen can calculate a number of parameters that are derived from measurements of: 

• Light intensity at different wavelengths (Scope) 

• absolute light intensity at defined range of wavelengths of the electromagnetic spectrum (Light meter) 

• quality of color space and color temperature of the light source (Chromaticity diagram) 

 

 

Please note that for proper lights spectra measurement, the SpectraPen device should be 

perpendicular to the light source for LM 510-H version and parallel with the light source for LM 510-V 

version. 

To perform the individual measurements please follow the next steps. 

• In the opening screen select Measure and the desired function (Fig. 5) 

• Scope (for Irradiance measurments over the range of the device) 

• Light meter (absolute light intensity averaged over the user specified range of wavelengths) 

• Chromaticity diagram (measurement of light color and correlated color temperature (CCT)) 
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Fig. 5 Selection of type of measurement. 

Scope 

Scope function is used for measurement of light intensity at different wavelengths (Fig. 6). Irradiance measurements 

display units as photon flux density in (µmol/m2/s/nm) or as irradiance in µW/cm2/nm. 

To perform the measurement select from the top menu of the main screen: Measure>Scope>Get Spectrum  

The spectra of the light source will be acquired, stored to the device memory and displayed on the screen.  

To change the units displayed please go to Options>Settings. 

 

Fig. 6 Scope. 

 

 

ES France - Département Bio-Tests & Industries - 127 rue de Buzenval BP 26 - 92380 Garches 
Tél. 01 47 95 99 90 - Fax. 01 47 01 16 22 - e-mail: bio@es-france.com - Site Web: www.es-france.com



© PSI (Photon Systems Instruments), spol. s r. o. 

 

14 
 

Light meter 

Light meter function is used for measurements of absolute light intensity at defined range of wavelengths (Fig. 7). Photon 

flux density measurements display units in micromoles per square meter per second, irradiance measurements are 

displayed in Watts per square meter and illuminance measurements are displayed in units of Lux. 

To perform the measurement select from the top menu of the main screen Measure>Light Meter>Get Spectrum 

Light intensity of the light source will be acquired, stored to the device memory and displayed on the screen as shown in 

Fig. 7    

 

Fig. 7 Light meter window. 

Please note that the Light Meter integrates the value based on the wavelength range defined. For LM 510/UVIS this is in 
range 340-780 nm. The user can define the wavelength range to be measured and use this tool to measure specific spectral 
regions of interest by going to Options>Settings and setting the required range (find more on page 18). To measure 
photosynthetically active radiation (PAR) change the settings and set the values from 400 to 700 nm.  

Chromaticity diagram  

Chromaticity diagram function is used for measurement of light color and correlated color temperature (CCT) using the 

International Commission on Illumination (CIE) techniques (Fig. 8). Chromaticity diagram function uses standard 

coordinates of the 1931 CIE colorimetric system by which all possible colours can be uniquely identified.  A color space is 

a uniform representation of visible light. It maps all of the colors visible to the human eye onto an x-y grid and assigns them 

measureable values. This allows us to make uniform measurements and comparisons between colors. 

To perform the measurement select from the top menu of the main screen: Measure >Chromaticity diagram> Get 

Spectrum  

The colour of the light source in the CIE1931 colorimetric system is marked by black cross. The x- and y- coordinates of the 

measured light source will be determined and the CCT value will be calculated and displayed on the screen.  

 

Please note that the CCT values are not automatically stored. 
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Fig. 8 Chromaticity diagram function. 
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7 MENU DESCRIPTION 

Measure 

This option is described in the Chapter 6.2 Measurement. 

Data 

• Browse (Fig. 9) – displays data browse dialog box. The user can browse the list of stored data, select the set of data 

files and view the light spectra in Scope mode. Colour classification of each data file helps the user to discriminate 

between individual measurements. PAR bookmark allows the user to view the light intensity in PAR spectral region 

for the acquired data. PAR is photosynthetically active radiation integrated in range 400-700nm. 

 

Fig. 9 Data browse. 

• Erase – erase function is used to erase internal data memory (Fig. 10) 

 

Fig. 10 Memory erase function. 

• Memory info (Fig. 11) – displays info on current amount of used internal memory in the SpectraPen LM 510 device 
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Fig. 11 Memory info. 

Options 

• Settings–this function is used to set various variable for the light measurements and for the device operation 

• Graph – displays options for setting the wavelength range and graph features (Fig. 12) 

Zoom enable – enables the zoom feature. With the stylus select an area (in the right-down direction) of the 

displayed graph which you want to zoom in. Reverse these steps if you want to return to the original display. 

Marker enable – enables to display exact numeric value for the point selected in the Scope graph window. Exact 

wavelength and light irradiance are displayed for the point touched on the graphical display. In top right corner 

of the LCD display the exact value of wavelength in nm is displayed for the user selected position of the spectrum. 

In addition, light irradiance for the given nm is shown.  

Smoothing – enables noise reduction of the graphical display by Smoothing the noise in the spectrum at the 

expense of spectral resolution. 

Wavelength range – defines the range of wavelengths considered for light meter measurements of Irradiance 

and Photon flux density. Desired wavelength range can be adjusted by selecting the wavelength and by using the 

arrows up and down.  

 

 

Please note that the wavelength range setting applies only for light meter. Light intensity measured 

in selected range is shown only on the SpectraPen display. The device saves to the memory the 

whole spectrum and light intensity calculated from the whole spectrum. 

 

The wavelength range setting is not active for Illuminance.  
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Fig. 12 Graph settings. 

• Time - displays actual time and date (all data files are stored by time and date signature). To change time and/or 
date specifications touch on one of the values and adjust it using the arrows (Fig. 13). 

 

Fig. 13 Time setting. 

• LCD – is used to adjust LCD display control settings (Fig. 14) 

Backlight intensity – move slider to adjust back light intensity in percentage 

Backlight time-out – move slider to adjust backlight time-out between 5 and 60 s (time of inactivity required 
before backlight will dim out to save battery life). 
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Fig. 14 LCD settings. 

• Device (Fig. 15) 

GPS – activates the GPS built-in module. The GPS coordinates cannot be displayed on the device display, but they 
are exported together with data and visualized in SpectraPen software on the computer after download.  

Average –Average function is used for adjusting the number of scans for each reading. Averaging of more scans 
results in a higher signal-to-noise ratio but increases the time required for each reading that appears on the 
screen. Move slider to set the number of measurement to be acquired for averaged values.  

 

Fig. 15 Device settings. 

 

Help 

• About…- information about the device, hardware and software version (Fig. 16). 
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Fig. 16 Information about the device. 
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8 PC COMMUNICATION 

8.1  USB CONNE CTION  

All SpectraPens come with the USB cable that is required for charging of the Li battery and for data transfer to PC.  

Please note that a lock-in system is used to secure the USB cable to the SpectraPen and extreme caution has to be used 

when setting up the connection. Otherwise damage to the cable pins may occur.  

 

When connecting the USB cable take extra caution to prevent damage to cable connector pins. 

Ensure that the cable is oriented correctly as shown in the photos below so the circled portion of the 

plug and the cable in photo A and B are perfectly lined up prior to pushing the cable into the device 

plug. Once this connection is achieved the cable may be secured in position by turning the metal 

cover of the cable and locking the cable in position. 

 

To connect SpectraPen with your computer please follow steps below in (Fig. 17). 

 

Fig. 17 A) Connector on SpectraPen device. B) Portion of the USB cable with pins. C – E) Position the cable horizontally, plug in the inlet 

and screw the securing screw. F) Correct connection of the USB cable and Pen device. 

 

8.2  DRIVER INSTALLATION  

For successful USB connection of the SpectraPen to the PC computer the USB driver and the SpectraPen software, included 

on the USB disk, need to be first installed on the PC. Without the driver installed the SpectraPen device will not be 

recognized by the computer and the connection to the software will be not possible. 

• Press Start and Select Control Panels (Fig. 18) 
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Fig. 18 Control panel 

• Navigate through System and security, System to Device manager (Fig. 19) 

 

Fig. 19 System window. 

• Connect the SpectraPen to the PC. You should see that PSI USB Device appears in the list. Right click on it and select 

Update Driver Software…( Fig. 20) 

 

Fig. 20 PSI USB Device. 

 

• Click Browse my computer for driver software and select Driver folder on the SpectraPen installation disk. Allow the 
installation even if the warning message appears (Fig. 21) 
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Fig. 21 Choose the driver from the USB disc. 

• Installation of the driver is now complete (Fig. 22) 

 

Fig. 22 Complete installation. 

 

In case this driver installation is not successful the driver may be downloaded directly from PSI 

websites www.psi.cz. 

Once the device is properly connected to the computer, the indicating icon appears on the SpectraPen device display Fig. 

23.  
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Fig. 23 Icon on the SpectraPen device display indicating the proper USB connection. 
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9 SPECTRAPEN SOFTWARE 

9.1  SOFTWARE INSTALLATION  

1. Copy the SpectraPen software provided on the USB flash disk to your computer and launches the SpectraPen 

program. 

2. To activate all software features register the software as follows (Fig. 24). 

• Select: Help > Register 

• Enter: your serial registration number (found in a text file SN.txt on the USB flash disk drive included with the 

device). 

• Select: OK  

 

Fig. 24 Software registration. 

 

It is not possible to download data from the SpectraPen device without software 

registration. 

3. Connect the USB cable to the computer. Then switch on the SpectraPen by pressing the Power button for a couple 

of seconds. 

4. Ensure that the PC and the SpectraPen are properly paired (see chapter 8). 

5. Connect SpectraPen device in SpectraPen software, Device > Connect (Fig. 25) 
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Fig. 25 SW connection. 

6. When the device is properly connected the left bottom corner of the SW window will display “SpectraPen” (Fig. 

26). Otherwise notification “Device: Not Connected” is displayed (Fig. 27). 

 

Fig. 26 SpectraPen connected. 

                

Fig. 27 Device not connected. 
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9.2  SOFTWARE MENU 

MENU: File 

Load    Loads previously saved data files. 

Save    Saves data to hard disc. 

Export    Exports data in .txt format. 

Export to JSON   Exports data in JavaScript Object Notation. 

Close    Closes the current experiment. 

Close All   Closes all open experiments. 

Exit    Exits the program. 

 

MENU: Device    

Connect    Detects and connects the device. 

Update Firmware  Used for firmware updates.* 

Attach GPS File Used to download data from the GPS module of 

the old version of the SpectraPen - LM 500. 

Memory Erase  Erases data from the SpectraPen memory. 

Online Control Online control of SP device. 

* For more information on firmware updating, see Chapter Firmware Update of this Operation Manual. 

 

MENU: Setup 

Update Software  Used for software updates. 

Settings On/off – Auto memory erase after download. 

 Selection of separator for the csv file after its 

export and following opening in Excel (TAB, 

SEMICOLON, COMMA, SPACE). 

 

MENU: Help 

Registration Used for the SpectraPen software registration.  

About Offers basic information about the program. 
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9.3  DATA TRANSFER AND VISUALIZATION  

1. After completion of measurement SpectraPen may be connected to PC for data download and further analysis.  

2. Launch the SpectraPen software on the computer and Connect the device. Go to Device> Connect. 

3. To transfer your data from the SpectraPen device to your PC use the Download function. Select icon on left side 

of screen or go to File and select Load if you want to process data stored on PC. 

4. All data stored currently in the SpectraPen device will be downloaded and shown in the main window view. The 

data are store and displayed/listed with the time stamp of measurement.  

 

Please note that if there are no data stored in the memory, the download function is not 

active. 

5. Visualization modes: Scope mode window is always displayed as the default. To view irradiance data go to 

Irradiance tab (Fig. 28). 

 

Scope mode represents non-calibrated spectrum. 

 

6. All data that are downloaded are displayed in the Scope window after download from the SpectraPen. The user 

can select the set of measurements to be displayed by marking and unmarking the data from the selection list 

(Fig. 28). 

 

7. Right click on list of measured data enables edit data name, delete selected measurement or show and hide all 

measured data in the graph– Select all measure and Clear all measure (Fig. 29). 

 

Fig. 28 Scope spectra. 
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8. In the graph marker feature is available, which enables display of the numeric values for wavelength and light 

irradiance for the selected wavelength of the scan (Fig. 30). Use the mouse to select the given point. In top right 

corner of the graph (red rectangle) is displayed exact value for the selected point on the x-axis and y-axis.   

 

Fig. 30 Marker feature. 

9. To zoom in on the data displayed in the graph select an area of the displayed graph (Fig. 31). To reverse these 

steps and return to original display use minus icon in the corners of the zoom area marked with red rectangles in 

Fig. 31. 

Fig. 29 Options for list of data. 
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Fig. 31 Zoom function. 

10. Select Irradiance tab to view the irradiance data stored either as umol/m2/s/nm or per uWatts/cm2/nm. To 

change the units in which the spectra is displayed click on the unit icon as shown in (Fig. 32). 

 

11. To view the light meter data for the spectral scans acquired click on the unit icon as depicted by red arrow in Fig. 

32. Irradiance and illuminance light meter numerical values for each scan are displayed as LUX, PAR or 

IRRADIANCE values (Fig. 32). 
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Fig. 32 Irradiance shown in different units. 

 

12. To Save the experiment select File>Save. All data stored in the device memory will be saved irrespective of the 

data selection in the SpectraPen software. The file will be stored as .spec. Spec files stores all Scope and Light 

meter data.  

Fig. 33 Numerical values of measured light intensities. 

ES France - Département Bio-Tests & Industries - 127 rue de Buzenval BP 26 - 92380 Garches 
Tél. 01 47 95 99 90 - Fax. 01 47 01 16 22 - e-mail: bio@es-france.com - Site Web: www.es-france.com



© PSI (Photon Systems Instruments), spol. s r. o. 

 

32 
 

13. Select File>Export to export the data in .txt format. Export function allows the user to specify the type of data. 

The options are: 

Spectrum – all raw scope data for entire range of measured wavelengths are exported including data for the dark 

scan.  

Spectrum scope – scope data normalised to dark spectrum scan are exported for all acquired scans or set of 

selected measurements. 

 

Fig. 34 Export options. 

Spectrum Irradiance – irradiance data for all measurements are exported. The user can choose to export the 

numeric values either in µE/m2/s/nm, µW/cm2/nm or both (Fig. 35).  

 

Fig. 35 Export of Irradiance spectrum. 

Computed Data – computed numeric values for Scope and Irradiance are exported for all measurements. The 

user can choose if only Scope numeric values or Irradiance numeric values are exported. For irradiance values, 

numeric data for Photon flux density and PAR in µmol/m2/s units, irradiance in µW/cm2 units and illuminance in 

LUX units are exported (Fig. 36).  

Export interpolation – if this option is marked the spectrum is exported with step of 1 nm. 
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Fig. 36 Export of computed values. 

 

9.4  ONLINE CONTROL  

Menu Online Control 

This function can be used for remote - online control of the SpectraPen device after connection with the PC. Online 

control enables to make changes in device setting and also perform remote measurement using PC.  

Select: Menu > Device > Online Control (Fig. 37) 

 

Fig. 37 Online control. 

Remote measurement (Fig. 38) 

Using this function Irradiance, Photon flux density and PAR can be measured.  

 

Please note that the Dark Spectrum Calibration should be done manually prior the remote 

measurement. Otherwise error ID:1 appears. 

• For manual remote measurement click on Get button. 

• Setting for automated remote measurement is possible using the button with three dots (next to “Get” button in the 

window of the software). Here the time interval of the measurement is set. To apply this setting use the option Use 
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settings (in “SettingsForm” window) and confirm by clicking OK. The measurement stars immediately and continues 

until it is manually stopped (Stop button).  

• Use the export option for exporting the data to .csv file. 

• Clear function serves for erasing of data measured by Online Control. 

 

 

Fig. 38 Remote measurement. 

Settings (Fig. 39) 

Here the following functions may be set up for remote operation of the SpectraPen: 

• Time synchronization of the device and PC 

• GPS built-in module activation (more information about the GPS module in chapter 7) 

• Averaging of measurement (1 – 10 measurements) 

• Selection of the wavelength range for measurements 

• Integration time (0 – 10 s) 
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Fig. 39 Online control settings. 

 

9.5  FIRMWARE UPDATE  

 

All data in the SpectraPen memory are erased during the firmware update! 

Before starting any firmware update, download all your data from the SpectraPen memory to the 

computer and save! 

 

Before firmware update ask the manufacturer for appropriate version of the firmware for your 

particular device. Incompatible firmware version can cause device malfunction. 

1. Starting Update 

• Select: Setup > Update Firmware From File 

2. Selecting .bxn file 

• Find firmware update file: Binary file (with the extension .bxn) 

• Select: Open. 

3. Finishing Upload 

• Select: OK to start uploading of the update 

• The bottom bar indicates the upload progress (Fig. 40) 

 

 

Fig. 40 Firmware update running. 
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10 GPS MODULE 

SpectraPen device LM 510 has integrated GPS module which may be turned on during the measurement for mapping of 

the collected data to specific field position. When GPS module is turned on, the map coordinates will be automatically 

saved with all collected data and will be downloaded during data download. 

 

For proper GPS reading, the time in your SpectraPen and in your computer must be synchronized. 

Preset time and time zone must correspond to GPS time (time zone) in your location. 

GPS / SpectraPen Operation 

1. Check the time setting on the SpectraPen device: Settings > Date & Time 

2. Switch the GPS module “ON” on the SpectraPen device by following these steps in the SpectraPen menu: 

• Select: Options > Settings > Device  

• Click on the check box for GPS (Fig. 41) 

 

Fig. 41 Activation of GPS. 

• Wait until the GPS position is found. The GPS module is ready when the icon of the position flag, in upper 

menu, stops flashing (Fig. 42). 
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Fig. 42 GPS active. 

 

 

For proper function of the GPS module the SpectraPen device may need a clear view of the sky to 

acquire satellite signal. 

3. Perform the selected measurements  

4. Connect the SpectraPen to the computer and open the SpectraPen software to proceed with download of the 

measured data. Data measured with activated GPS module are downloaded with GPS coordinates (Fig. 43). 

 

Fig. 43 Data with GPS coordinates. 
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11  WARRANTY TERMS AND CONDITIONS 

• This Limited Warranty applies only to the SpectraPen device. It is valid for one year from the date of shipment.  

• If at any time within this warranty period the instrument does not function as warranted, return it and the 

manufacturer will repair or replace it at no charge. The customer is responsible for shipping and insurance 

charges (for the full product value) to PSI. The manufacturer is responsible for shipping and insurance on return 

of the instrument to the customer.  

• No warranty will apply to any instrument that has been (i) modified, altered, or repaired by persons 

unauthorized by the manufacturer; (ii) subjected to misuse, negligence, or accident; (iii) connected, installed, 

adjusted, or used otherwise than in accordance with the instructions supplied by the manufacturer.  

• The warranty is return-to-base only, and does not include on-site repair charges such as labor, travel, or other 

expenses associated with the repair or installation of replacement parts at the customer's site.  

• The manufacturer repairs or replaces faulty instruments as quickly as possible; the maximum time is one month.  

• The manufacturer will keep spare parts or their adequate substitutes for a period of at least five years.  

• Returned instruments must be packaged sufficiently so as not to assume any transit damage. If damage is 

caused due to insufficient packaging, the instrument will be treated as an out-of-warranty repair and charged as 

such.  

• PSI also offers out-of-warranty repairs. These are usually returned to the customer on a cash-on-delivery basis.  

• Wear & Tear Items (such as sealing, tubing, padding, etc.) are excluded from this warranty. The term Wear & 

Tear denotes the damage that naturally and inevitably occurs as a result of normal use or aging even when an 

item is used competently and with care and proper maintenance.  
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12 TROUBLESHOOTING AND CUSTOMER SUPPORT 

In case of troubles and for customer support, please, visit FAQ on our websites, write to support@psi.cz or contact your 

local distributor. 
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13 APPENDIX 

13.1  PROGRAM MING CUSTOM INDEX IN SPECTRAPEN 

The SpectraPen software enables programming custom indexes, which can be used for wide range of calculation based on 

the measured spectrum.  

1. Go to the main SpectraPen folder in your PC (Usually in Program Files). 

2. Open the file Config > Formulas.txt. 

3. Write your index into this .txt file and save it (Fig. 44). 

Index example: 

Scope:PSIindex:PSI test index:Scope[600nm]/ Scope[500nm] 

 

Scope – the index is placed in the bookmark Scope in data in the software 

PSIindex – name of the index in the SpectraPen software and in exported data 

PSI test index – full name of the index (not showed) 

Scope[600nm]/ Scope[500nm] – equation for calculation; calculated from 500 and 600 nm of Scope spectra 

 

4. Restart the SpectraPen Software. 

5. The new index appears in the selected bookmark in the data (Fig. 45). 

6. For export of this index choose the option “Computed values” and selected spectrum in the export table. 

Fig. 44 New index in the Formulas file. 
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Fig. 45 New index. 

 

Function description 

Different mathematical functions can be used in SpectraPen software syntax to create new custom formulas. 

min, max -  

min(value1, value2) 

value1 - number, variable, function 

value2 – number, variable, function 

- only one value can be function! 

min(array) 

array – array of numbers  

 

example1: max(Scope)  

example2: min(Irradiance)  

example3: min(Scope[760nm], max(Scope[450], Scope[680])) 

example5: max(Irradiance[550nm], (5+4)*4) 

__________________________________________________________________________ 

ln – the natural (base e) logarithm of specified number 

ln(value) 

value – number, variable, function 
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example1: ln(5) 

example2: ln(Irradiance[760nm]) 

example2: ln(max(Irradiance [550nm], Irradiance[480nm])) 

example5: ln((5+4)*4) 

__________________________________________________________________________ 

log – the logarithm of specified number in a specified base. 

logB(value)  

B – base - number 

value – number, variable, function 

 

example1: log2(5) 

example2: log5(Scope[760nm]) 

example3: log10(max(Scope[550nm], Scope[480nm])) 

example4: log10((5+4)*4) 

__________________________________________________________________________ 

sqrt – the square root of a specified number 

sqrt(value) 

value – number, variable, function 

 

example1: sqrt(5) 

example2: sqrt(Scope[760nm]) 

example3: sqrt(max(Scope[550nm], Scope[480nm])) 

example4: sqrt(((5+4)*4) + 6) 

____________________________________________________________________________ 

^ - spedified number raised to the specified power 

value^power 

value – number, variable, function 

power – number, variable, function 

 

example1: Irradiance[760nm]^ Irradiance[550nm] 

example2: min(Irradiance[760nm], Irradiance[550nm])^max(Irradiance[435nm], Irradiance[430nm]) 
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example3: Transmitance[760nm]^0.5 

___________________________________________________________________________ 

integral - express the area under the curve of a graph of the function in the interval 

integral(function_values, from, to) 

function_values – input values for integral compute 

from,to – limit values 

 

example1: integral(IrradianceL, 360nm, 700nm) 

example2: integral(IrradianceE, 360nm, 700nm) * IrradianceE[450] 
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